StageTools - Documentation [Prev][Up][Skip][Next]

Other Software Required by StageTools:

All the StageTools modules are written in TCL/TK, so you must have TCL/TK installed on your system. This is available from http://www.scriptics.com/. StageTools requires version 8.0 or later of TCL/TK.

CenterStage will run without any additional software, but the other tools require some other unix programs to do part of their work. In particular, you must have programs for converting PPM images to the formats you are interested in using (usually GIF, TIFF or JPEG), a program for converting image files into MPEG movies, and a program for converting GIF files into an animated GIF file. StageTools is set up to use the ImageMagick package as its image conversion tool, mpeg_encode as its mpeg encoder, and gifmerge for its animated GIF maker. The following links take you to FTP sites where you can download these packages:

If you want to use programs other than these, you will need to customize StageTools to suit your needs.

If you can not find or install all these tools, you can still run StageManager in preview mode. If you don't have ImageMagick (or some replacement for it), you will not be able to save frames or images; if you don't have mpeg_encode, you will not be able to create MPEG movies; and if you don't have gifmerge, you will not be able to save animated GIFs. Except for these functions, StageManager and the other tools should operate properly even without these tools.


[HOME] StageTools Documentation web pages
Created: 20 Aug 1997
Last modified: Aug 17, 2006 9:33:59 AM
Comments to: dpvc@union.edu
[Next] Customization Instructions
[Skip] Getting Started with StageTools
[Prev] Installation Instructions